
When building a Help file, you don’t have to create text-only files–you can add 
interest and clarity by using pictures. This chapter describes different ways to 
include pictures in your Help files and discusses issues you should consider when

obtaining and preparing pictures for a Help file.

You can create pictures for your Help file using whatever tools you want, 
including many popular graphics programs for Microsoft Windows or the Apple 
Macintosh. The main requirement is that Windows Help must be able to display 
the image. 

Sources

In order to create good quality pictures, you should consider different source 
materials. The most obvious source is the application, which contains the 
interface elements most Help files document. However, magazines, illustrated 
encyclopaedias and catalogs are also good sources of visual material. Another 
source might be physical objects, which can be photographed, scanned (if they 
are fairly flat), measured, or drawn.

Professional designers continually use visual references for their work. For 
example, if producing a design that features airplanes, the designer will collect as 
many photographs and detailed drawings as possible. By referring to a collection 
of pictures, the designer can produce an original picture which is convincing and 
accurate.

When determining the style of a picture it may be worth studying the work of 
professional illustrators in magazines, advertisements, books, and so on. Care 
should be taken not to confuse simple with badly drawn images. Simple designs 
are often very successful since they focus the user’s attention on the key aspects 
of the picture. For instance, a silhouette of an object is often quite sufficient for it 
to be recognized.

If you use a picture that has been published without permission and without 
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changing it in any way, then you may be infringing on someone’s copyright. In 
this case you should either seek permission from the publishers or adapt the 
picture for your own use. The original picture, when appropriate, should be 
acknowledged in your documentation.

Picture Quality

When creating pictures, you should consider the overall quality that users expect. 
Since the pictures appear on an electronic screen, users may expect the pictures 
and screen design to fall somewhere between the standards set by television and 
computer arcade games. It is important to try to meet users’ visual expectancy 
since the impact of poorly designed images can cause users to lose interest.

An important difference between printed images and online images is their 
resolution. The resolution of paper-based images is generally much higher than 
images on the computer screen.

Don’t use images with too much detail at a small scale since the detail will likely 
be lost on the screen. Conversely, an enlarged image which is only partly visible 
can add another dimension to screen presentation.

Watch out for “staircasing” on lower resolution monitors. This is the stepped 
effect caused when displaying sloping lines. It can be avoided by using only 
vertical and horizontal lines and alleviated with lines at 45 degrees.

Tools and Methods

You can use a number of methods to create pictures for your Help file. Each 
method will influence the visual appearance of the picture as well as your 
approach to design. If possible, try to match the strengths and weaknesses of the 
method used to create the picture to the kind of image for which it is best suited. 

The resolution and accuracy of any device will affect the quality of the final 
image. Also, many methods require some ability to draw. Employing a 
professional designer for this work (unless there is one in the team) should be 
considered–they will probably save time and produce better results.

For example, you can use any of the following methods to create pictures:

n Use the Windows screen capture facility to take a screen shot and 
then edit the bitmap in Windows Paintbrush.
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n Use a graphics application to create the picture from scratch.
n Use a scanner to capture existing illustrations or clip art.
n Use a digitizing tablet to trace an image.
n Import a picture created using a Macintosh graphics application.

Each picture that you include in the Help file must be saved as a separate file. 
One way to manage pictures for a project is to create a subdirectory where all 
pictures are stored, such as an \ART subdirectory in the project directory.

When building the Help file, the Help compiler can compress bitmap files 
(including .SHG files) if you specify Medium or High using the COMPRESS 
option in the [OPTIONS] section of the Help project file. On the average, you 
can expect 25 percent to 50 percent reduction in size using compression. (For 
details, see Chapter 16, “The Help Project File.”)

Picture Formats
Pictures that appear in Help files must be in one of the following standard 
Windows formats.

Format Description

.DIB Windows version 3.x device-independent bitmap

.BMP Windows version 2.x bitmap

.WMF Windows metafile

.SHG Windows Help hypergraphic bitmap
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Several applications, such as Microsoft Word for Windows, Micrografx® 
Designer, Corel® Draw, and Aldus® PageMaker® and FreeHand®, and others 
can save files or export them as metafiles. However, some applications, Aldus 
FreeHand, for example, use a metafile format that differs somewhat from the 
standard metafile format for Windows. For that reason, you can’t use their files 
directly. You must convert them to the standard metafile format for Windows or 
convert them to bitmap files. 

Note

If Help cannot display the file because it is in an unsupported 
format, you can take a screen shot of it, paste it into Windows 
Paintbrush, and then save it as a Windows-based bitmap. If you can’t 
display the picture in Windows, you must use a conversion utility to 
convert the file to a supported format.

Note

Because Windows-based metafiles are not binary compatible 
with the Macintosh, you should use only bitmaps if you want to ensure 
cross-platform compatibility.

Creating Bitmaps from Screen Shots
Another easy way to create art for your Help file is to use the Windows screen 
capture facility. Using screen shots, you can create a bitmap from anything that 
you can display in Windows–a window, dialog box, or icon, for example. You 
can also use this method to convert unsupported picture formats into Windows-
based bitmap format. For example, you may want to use a full-featured draw 
program to create art for your Help file but save the final pictures as bitmaps. 
You can do that just by previewing the finished art in Windows. When the image 
displays in Windows, you can copy it to the Clipboard and paste it into a graphics
editor such as Windows Paintbrush. Then you use the graphics editor to clean up 
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the image as needed, and save the image in an appropriate format.

To create a bitmap from a screen shot

1. Display on the Windows desktop the element you want to make into 
a picture.
For some shots, this may require a special setup–starting the 
application, opening a document, scrolling to a specific location, and so
on.
2. Press ALT+PRINTSCREEN to copy a picture of the active window 
to the Clipboard.
3. Open Paintbrush.
4. From the View menu, choose Zoom Out.
Zooming out ensures that Paintbrush will capture the entire screen 
dump.
5. From the Edit menu, choose Paste.
6. Select any Paintbrush tool.
Paintbrush displays a zoomed out version of the screen dump.

Graphic
7. From the View menu, choose Zoom In.
The screen shot appears full size.
8. Make any changes you want to this piece of art.
9. Use the Pick tool to select the portion of the drawing you want to 
save as the final bitmap.

10. From the Edit menu, choose Copy To.
11. Save the file as a Windows bitmap.

Creating Pictures from Scratch
Both paint and draw programs are now widely available. Paint programs are well-
suited to freehand-type illustrations. They include many features such as facilities
for brushes, lines and shapes, filling areas with colors and patterns, image 
manipulation, and so on. Draw programs are better suited for creating mechanical
or structured images. Generally, they take longer to learn to use than paint 
programs, but they allow greater flexibility in editing the details of the drawing. 
Unlike pictures created by paint programs, pictures created in draw programs can
contain multiple layers, each of which can be manipulated independently.
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Painting and drawing programs are based on two very different ways of 
describing a picture. Painting software uses an array of color pixels (or bit maps) 
to represent the image. Drafting or object orientated software describes pictures 
as a list of graphic primitives such as line or circle which have a number of 
attributes such as position and size.

Creating graphics from scratch may pose a large problem for the inexperienced 
Help author because their use seems to require the ability to draw. Frequently 
there appears to be a bewildering variety of shapes, styles, colors, patterns, and 
specialized tools to choose from. However, creating effective graphics often 
depends to a large extent on applying sound principles, rather than on pure artisitc
skill. The documentation that comes with your graphics editor should provide 
some direction and guidelines for designing and creating graphics. And if you 
want to provide a more professional look to your pictures, you can have them 
created by a competent graphic designer or illustrator.

Microsoft Windows does not include a draw program, but it does offer a basic 
paint program–Windows Paintbrush. You can use Paintbrush to create freehand 
illustrations and prepare screen images of your application or the Windows 
environment. The procedure for creating a simple drawing in Windows 
Paintbrush involves the following steps.

To create a simple drawing in Windows Paintbrush

1. Start Paintbrush.
2. Determine the size of the drawing area.
You define the drawing area by choosing the Image Attributes 
command from the Options menu. Frequently, it is a good strategy to 
use the default drawing area (equivalent to the entire screen) while you 
are creating the drawing so that you have more room to work. When 
you are ready to save the drawing, you can define the size of the final 
art.
3. Select a background and foreground color.
You can change from a color palette to a black-and-white palette (or 
vice versa) by choosing the Image Attributes command from the 
Options menu. However, after you begin a drawing, you must stay with
the palette you selected.
4. Select a drawing tool.
In most cases, you will use several tools to create a picture.
5. Draw the picture.
If you make a mistake while drawing, you can use the Undo command 
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on the Edit menu and the Eraser tool.
6. Make any changes or edits to the picture.
If you need to see the drawing in greater detail to make fine 
adjustments, you can use the Zoom In command on the View menu. 
The Zoom In command magnifies a portion of the drawing so you can 
change one pixel at a time.
7 When the picture looks the way you want it to, save it as a Windows 
16-color bitmap.
Make sure that you save just that portion of the drawing that you want 
to appear in Help and not the entire drawing area (if the drawing area is 
larger than the picture you are creating). 

For complete instructions on how to use Paintbrush to create pictures, see the 
Microsoft Windows User’s Guide, version 3.0 or 3.1. If you are using a different 
graphics editor to prepare your pictures, see the user’s guide for the graphics 
application you are using to learn how to create the pictures.

Creating Realistic 3D Graphics

When an object is displayed in two dimensions, as in a drawing, depth 
relationships, such as whether one line is in front of or behind another, are often 
ambiguous. On the other hand, when perceiving an actual solid object or scene, 
the human eye uses certain information, sometimes referred to as depth cues, in 
order to deduce the spatial structure. 

You can include some of these cues, such as occlusion (closer objects overlap 
those that are further away) and shading, in order to make your pictures more 
realistic. There are various ways of showing depth with three-dimensional 
images. You can:

n Remove lines that would be obscured by opaque surfaces. This helps 
clarify the location of lines and objects.

n Make lines that are further away less visible in the picture, by using 
dotted or fainter lines.

n Paint the faces of an object in different colors in order to indicate the 
existence or absence of surfaces.

n Shade the faces of an object to different intensities according to the 
direction of the light. This method improves the realism. In Windows
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the light source is always assumed to be above and to the left of an 
object, as you can see by looking at the shading on any command 
button.

Creating Pictures from Scanned Images
Scanning images is one of the easiest ways to include graphics in the Help file 
because the most difficult task–creating the image–has already been done. You 
only have to work the scanning software and then perform final cleanup and 
editing in Windows Paintbrush or some other graphics application. 

The problem with most scanned color images, however, is that they need at least 
256 colors to look realistic when they are displayed on a computer screen. 
Because Windows Help does not support 256-color pictures, and also because 
256-color pictures often do not display adequately on systems with standard VGA
(16-color) video adapters, you are limited in the kind of images you can scan for 
use in Help files.

Sixteen-color pictures are suitable for diagrams, line drawings, cartoons, and 
simple drawings, most of which can be scanned successfully. Also, there is an 
increasing amount of public clip art available that would be suitable to scan. The 
goal is to offer the highest possible image quality to users with low-end video 
hardware but avoid short-changing users with more powerful video capabilities. 
If you can use a scanner to obtain pictures that meet Help’s basic requirements, 
then scanning is a good way to create graphics for your Help file.

Creating Bitmaps with a Digitizing Tablet
A digitizing tablet is the best way to trace the outline of an existing image and 
ensures that the proportions are correct. A mouse or a tablet can be used to copy a
picture by eye, but this requires more skill than tracing. 

Tablets are based on an absolute coordinate system, while mice use relative 
coordinates: this affects the physical drawing action and is the principal reason 
why mice are not good for tracing. 

Digitizing tablets can be fitted with a stylus (like a pen) which is good for 
freehand drawing or a transparent cross-hair cursor which is good for accurate 
tracing and for positioning elements on screen. Mice are also good for positioning
elements.
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Creating Pictures on the Macintosh
Many graphics artists use the Apple Macintosh computer as their primary tool for
creating art. Although the file formats most commonly used by Macintosh 
applications are not supported by Windows Help, you can use the Macintosh 
computer to create art for your Help file. Basically, you have two options:

n You can use a Macintosh draw or paint program to create the art and 
convert the files to a standard Windows graphics format.

n You can insert art in a Word for the Macintosh document and then 
import the entire document to Word for Windows and capture the art 
in screen shots.

Importing Art from Macintosh Graphics Applications

Most draw and paint programs that run on the Apple Macintosh have the ability 
to save files in PICT format. Since there are several ultilities that convert graphics
files from PICT to DIB format and from DIB to PICT format, you can create art 
for your Help file using your favorite Macintosh graphics application and then 
transfer the art to the PC so it can be built into the Help file. You can also move 
original art and screen shots Windows saved in DIB or BMP format to the 
Macintosh application and edit them there.

To move art back and forth between the Macintosh and PC, you need the 
following tools:

n A conversion utility that can convert the file formats you are using. 
Alchemy is one example.

n Network hardware and software that connects the PC and Macintosh 
computers or software like DOS Mounter that enables Macintosh 
computers to read and write to MS-DOS 3.5-inch floppy disks 
formatted on the PC.

n A palette file in the Macintosh application that matches the standard 
Windows 16-colors.
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Some Conversion Issues

When importing art created by Macintosh applications, you should be aware of 
the following issues:

n When transferring files from Windows to the PC, the Macintosh 
graphics application may not be able to see the files in its Open list 
box.

If this happens, it is probably because the converted file has the wrong 
TYPE and CREATOR set. You can change these settings manually 
with Macintosh utilities such as DiskTop; however, DOS Mounter and 
some network software (Microsoft LANManager 2.1, for example) 
perform automatic extension mapping, which assigns the proper TYPE 
and CREATOR to a file with a particular MS-DOS file extension 
whenever a file is moved to the Macintosh.
n Because Windows Help only supports bitmaps with 16 colors, you 

should create a custom “Windows 16-color palette” for your graphics
application.

That will ensure that the art you create and edit on the Macintosh will 
display with the correct colors when transferred back to Windows. If 
you want to use dithered colors that are found in Windows Paintbrush, 
you may need to create those as well, for example as custom brush 
patterns in Studio/8.
n Some graphics applications on the Macintosh save files with a 

minimum 256-color depth (8-bit color).
If this is true, make sure that the conversion utility reduces the file to 16
colors (4-bit color) when it converts it to a bitmap. Or open the 256-
color bitmap in Paintbrush and save the file as a 16-color bitmap. 
Storing bitmaps on the PC in 16 colors will also keep file sizes to a 
minimum and conserve disk space.
n MS-DOS only accepts filenames that have 8 characters plus a 3-

character extension.
Because the Macintosh does not have this limitation, you should follow 
the MS-DOS 8-character naming convention when naming the art you 
create on the Macintosh, and use the .PIC extension. Otherwise, the 
filenames of graphic files you transfer may be difficult to interpret.
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Using Batch Files to Control the Conversion Process

If the conversion utility you are using runs in MS-DOS, you may want to create a 
batch file to control the conversion process. Batch processing ensures consistency
in the conversion routine and also allows you to convert many files at the same 
time. The following example shows one way to set up a batch-file process for 
converting art between the Macintosh and PC. 

The first batch file converts Windows BMP files to Macintosh PICT format:
@echo off
break on

if "%1" == "" goto ERROR

echo.
echo Converting BMP file to PICT format...
echo.

:RESTART
for %%p in (%1) do c:\tadpole\alchemy -mo %%p
shift
if not "%1" == "" goto RESTART
goto MOVEFILE

:ERROR
cls
echo This batch file converts Windows BMP files to Mac PICT format.
echo Wildcards and multiple sets are allowed.
echo Syntax is:
echo.
echo %0 file(s).BMP
echo.
echo where file(s) = separate file names and/or wildcards.
echo.
goto EXIT

:MOVEFILE
echo.
echo Conversion complete.
echo Now moving file to EDITS\PICT folder...
echo.
copy *.pic ..\edits\pict
del *.pic

:EXIT
echo.
echo All done!

The second batch file converts Macintosh PICT files to Windows BMP format:
@echo off
break on
if "%1" == "" goto BIGERROR
set loc=%1
echo.
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echo ---------------
echo !!! WARNING !!!
echo.
echo If you are processing art for existing SLM
echo art files (that have already been 'addfile'd), you MUST first
echo check out the file(s). Otherwise the edits and changes will be lost!
echo.
echo Press the CTRL+C keys to stop this batch file, or pause
direxist \archive\%loc%
if errorlevel 1 goto ERROR1
goto PICT2ARC

:ERROR1
echo.
echo     \\TOAD\MAC!ARCHIVE\%loc% does not exist.
echo     Please check the spelling of the directory name
echo     or confirm you are starting from the net drive.
echo.
goto EXIT

:PICT2ARC
echo.
echo     Placing copy of PICT files in \\TOAD\MAC!ARCHIVE\%loc%...
echo.
copy *.pic \archive\%loc%
direxist c:\tadpole\%loc%\art
if errorlevel 1 goto ERROR2
goto PICT2C

:ERROR2
echo.
echo     C:\TADPOLE\%loc%\ART does not exist.
echo     Please check the spelling of the directory name.
echo.
goto EXIT

:PICT2C
echo.
echo     Moving files to C:\TADPOLE\%LOC%\ART...
echo.
copy *.pic c:\tadpole\%loc%\art
del *.pic
c:
cd \tadpole\%loc%\art

:CONVERT
echo.
echo     Converting PICT files to BMP...
echo.
for %%p in (*.pic) do c:\tadpole\alchemy %%p -wo -D -f c:\tadpole\bmp16.pal
del *.pic
echo.
echo     Now, addfile or check in the .BMP files...
echo.
goto EXIT

:BIGERROR
cls
echo This conversion starts from the server drive, copies ALL the
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echo PICT files to the net archive directory, then moves those files 
echo to your C: drive in the appropriate \TADPOLE SLM project 
echo directory and performs the conversion. Part of the conversion
echo limits the colors of the PICT files to the basic Windows 16 colors.
echo.
echo Syntax is:
echo.
echo       PREP4PC (location)
echo.
echo (location) is the name of the application subdirectory.
echo For example, the syntax:
echo.
echo       PREP4PC calc
echo.
echo would place the final converted file(s) in 
echo the C:\TADPOLE\CALC\ART directory.
echo.

:EXIT
set loc=
break off

Importing Art From Microsoft Word for the Macintosh

If you have art that is stored in Word for the Macintosh files, you can import that 
art into Word for Windows and use it in your Help file. To convert the art, you 
import the Word for the Macintosh document to Windows and then take a screen 
shot of the art and save it in Paintbrush as a Windows bitmap.

To import art from a Word for the Macintosh file

1. Save the Word for the Macintosh file as RTF.
2. Open the RTF file in Word for Windows.
3. Select the picture you want to use in your Help file.
Note     If you are using Word for Windows version 2.0, do not double-
click the piece of art, or Word will convert the picture into an 
embedded Draw graphic. If that happens, you will not be able to paste 
the picture into Paintbrush.
4. Copy the picture to the Clipboard.
5. Open Paintbrush.
6. From the Edit menu, choose Paste.
7. Make any changes you want to the picture.
8. When the art looks the way you want it to, save it as a Windows 16-
color bitmap.
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One important issue to consider when creating graphic images is how the pictures
will appear on different video displays. Help can display graphics on computers 
with many different kinds of video hardware, including the most common display
types–monochrome, color, EGA, VGA, and 8514. When you prepare pictures for
Help, you should analyze the target audience for the Help file and determine what
percentage of that audience has monochrome or color displays, and what 
percentage has each type of video adapter so that you can create pictures that will
look good on the end-user’s machine. 

Because Windows Help is device independent, it stores text and graphics by point
size rather than by their width and height in pixels. When displaying bitmaps, 
Windows Help tries to maintain a bitmap’s logical size across all displays (EGA, 
VGA, or 8514, for example). When displaying bitmaps, Help sizes text and 
graphics proportionately by preserving the authored point size of the text or 
bitmap file. Because screens have different point sizes based on their resolution, 
bitmaps take up different proportions of the screen. This means that a picture will
distort unless the author’s display and the user’s display have the same resolution.

Therefore, to make certain that the pictures you create display correctly on the 
user’s display, you should create pictures in the same screen resolution (EGA, 
VGA, VGA+, or 8514) that you want Windows Help to use when it displays the 
topics on the user’s computer. For example, if most of your users have VGA 
adapters, you should create the pictures on a machine with standard VGA 
resolution. (For more information about supporting multiple display resolutions in
Help, see Chapter 12, “Creating Graphics for Different Displays.”)

When creating color pictures for Help files, Windows Help assumes that your 
pictures have 16 or fewer colors. If you don’t use Windows Paintbrush to create 
the pictures, the color palette in your paint program should have no more than 16 
colors. Since Windows Help supports only 16-color pictures, you don’t need to 
worry about palette conflicts–all pictures use the standard Windows system 
palette. However, you may have to make palette adjustments in the graphics 
application, especially if the graphics program has 256-color support. If you 
create a monochrome bitmap using Word for Windows, the monochrome bitmap 
uses the window’s foreground and background colors.

Preparing Pictures for Different 
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The descriptions in the remaining sections of this chapter assume that you’ve 
identified and prepared the pictures you want to include. If you need more 
information about preparing pictures, see the user’s guide for the graphics 

application you are using.

After you create and prepare the pictures for your Help file, you can place them 
in a topic file in two ways.

n You can paste the pictures directly in the topic, if your word 
processor supports Windows version 2.1 or later graphics.

Pictures placed using this method are referred to as inline bitmaps.
n You can save each bitmap file in your graphics application and, in 

the Help topic file, specify the file by name where you want it to 
appear.

Pictures placed using this method are referred to as bitmaps by 
reference, because the topic contains only a reference, or pointer, to the 
bitmap file, not the actual picture itself.

Each method has advantages and disadvantages. Use the information in the 
following sections to help you decide which method to use.

For detailed information about topic layout, including the effects of margins and 
paragraph leading, see Chapter 3, “Designing Your Help System.”

Placing Pictures Directly in the Topic File

Pictures placed directly in a topic appear like pictures on a page in a book. To 
place the picture in a topic, you import the bitmap directly from the Clipboard 
into Word for Windows, and then paste the picture where you want it in the topic.
You can format the topic text so that it is positioned below or alongside the 
bitmap. When you save the topic file as RTF, the pasted-in bitmap is converted 
and included in the Help file.

Placing Graphics in Topic Files
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The advantages to using this method are:

n You can see the picture whenever you work in the topic file.
n You don’t have to tell the compiler where to find the bitmap files 

when building the Help file.

The disadvantages are:

n Using the same picture more than once will increase the size of the 
Help file.

n Bitmaps pasted directly into Word for Windows cannot exceed 64K. 
If they do, the Help topic will cause an out-of-memory condition 
during the build, and the compiler will abort the build.

n You can use only inline bitmaps (those treated the same as a 
character) in a Word for Windows document, which limits how you 
can display text and graphics in your Help file. For example, you 
cannot wrap text around an inline bitmap.

n Pictures inserted directly into a Word for Windows document affect 
performance, especially when scrolling or saving documents.

n You cannot change the picture inside Word for Windows. Instead, 
you must modify the picture in your graphics application and then re-
import it into Word for Windows.

n You cannot use graphics with multiple hot spots in your topic files. 
For more information, see Chapter 11, “Creating Hypergraphics.”

n Only Word for Windows lets you include bitmaps directly in the 
topic file. So, you cannot use a Macintosh word processor, such as 
Microsoft Word for the Macintosh, to create any of your RTF topics.

Placing Bitmaps in Word for Windows
Word for Windows treats bitmaps as a single, very large character. How a bitmap
displays on the screen, however, is determined in part by the printer you select. 
The bitmap sizes shown in the Format Picture dialog box are based on the pixel 
size Word for Windows associates with the printer and its printing resolution. 
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Generally, if you insert a bitmap and select Display As Printed (version 1.1) in 
View Preferences (or Line Breaks and Fonts As Printed in version 2.0), the actual
ruler size of the bitmap is the same as that indicated by the dialog box.

If you cancel Display As Printed, change printers, or change the display 
resolution (from EGA to VGA, for example), the size in the Format Picture 
dialog box changes. When Display As Printed is canceled, Word for Windows 
assumes the pixels are screen pixels. Distortions in the displayed bitmap may 
result from the difference in size between screen pixels and printer pixels.

In Word for Windows, every bitmap has a frame around it. The frame is invisible,
however, unless you select a border from the Format Picture dialog box.

A bitmap that is visible in the topic file often appears as a blank box while you 
are typing. Similarly, as you move through the topic file, picture frames are blank
to speed scrolling and typing. When you pause, Word for Windows fills in the 
picture(s).

Importing Bitmaps into Word for Windows
After creating your bitmaps, you can copy them to the Clipboard and then paste 
them into your topic file using Word for Windows.

To insert a bitmap into a topic file

1. Copy the bitmap from your graphics program to the Clipboard.
2. Position the insertion point where you want the bitmap to appear in 
the topic file.
3. From the Edit menu, choose Paste.
Or press SHIFT+INS.

Selecting Inline Bitmaps with the Mouse
Before you can do anything with the bitmap, you have to select it. To select a 
pasted-in bitmap, click inside the picture frame. When you select a bitmap, eight 
sizing handles appear on the picture frame: one on each side and one on each 
corner, as in Figure 10.x.

Graphic
Sizing Pasted-In Bitmaps
Once you select a bitmap, you can use the sizing handles to change its size by 
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scaling it. The handles move both toward and away from the center of the bitmap.

To scale a pasted-in bitmap

1. Select the bitmap.
2. Hold down the SHIFT key while you drag the sizing handles to change
the scaling of the image.
When you drag the sizing handles, scaling information appears in the 
status bar. Measurements are in percentages of the original image size.

Formatting Inline Bitmaps as Hot Spots
You can do more with bitmaps in your Help file than simply display them. 
Windows Help lets you use bitmaps as hot spots. You can create graphics, such 
as icons or buttons, and use them as jumps to particular topics or as hot spots for 
pop-up windows or Help macros.

To format an inline bitmap as a hot spot

1. Select the bitmap in the topic file that you want to format as a hot 
spot.
2. From the Format menu, choose Character.
3. Select the Double Underline check box, and then choose OK.
Or select the Underline check box if you want to create a pop-up hot 
spot.
4. Position the insertion point to the immediate right of the bitmap.
Leave no spaces or characters between the bitmap and the insertion 
point.
5. From the Format menu, choose Character.
6. Clear the Double Underline check box, select the Hidden check box, 
and then choose OK.
Or clear the Underline check box if this is a pop-up hot spot.
7. Type the context string of the destination topic for the jump.
Or type the context string assigned to the pop-up topic.
Or type an exclamation point (!) followed by the macro and its 
parameters if you want Windows Help to execute a macro when the 
user chooses this hot spot.
8. From the Format menu, choose Character.
9. Clear the Hidden check box, and then choose OK.
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Placing Bitmaps by Reference in the Topic File

To achieve finer control over the placement of a picture, you can place a bitmap 
reference in the topic. The bitmap reference is like a coded message that tells the 
compiler the name of the bitmap file and how to position the picture with respect 
to the topic text. When Windows Help encounters a bitmap reference, it inserts a 
reference to a central location in the Help file where the picture is stored. The 
Windows Help application uses this referenced information provided by the Help 
compiler to display the picture.

You can use bitmap references to display a variety of pictures in Help, from tiny 
bullet characters to full-screen illustrative art. The advantages to using bitmap 
references are:

n You have the widest range of options for positioning the picture with 
text. For example, you can treat the picture as a text character, or you
can wrap text around the left or right edge of the picture.

n You should not notice any change in the performance of Word for 
Windows; bitmaps included by reference do not affect it any more 
than text does.

n You can change the graphic as often and as much as you like without
changing the reference in the topic file. The references are simply 
pointers to the actual bitmap files.

n You can use hypergraphics (pictures with hot spots) in your topic 
files. In fact, hypergraphics must be included by reference. For more 
information, see Chapter 11, “Creating Hypergraphics.”

n You can use any text editor that produces RTF files to create your 
Help topics, including Word for the Macintosh.

The disadvantages are:

n You can’t see the graphic when you are working in the word 
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processor.
n You must tell the compiler where to find the actual bitmap files 

referenced in the topic files when you build the Help file. Although 
this is a simple task, mistakes in this process will cause errors when 
you compile the Help file.

Including Bitmaps by Reference
To include bitmaps by reference in a topic file, you must make the following 
changes to the topic and Help project file:

n Enter a reference command in the topic file where you want the 
picture to appear.

n Make an entry in the Help project file that tells the compiler where to
find the bitmap files referenced in the topic files.

Help supports three different positions for bitmaps included by reference–
character, left-aligned, or right-aligned. Each position defines how the bitmap is 
placed with respect to text, and each position requires a slightly different 
command reference in the topic file:

character {bmc bitmap-filename}

left-aligned {bml bitmap-filename}

right-aligned {bmr bitmap-filename}

Positioning Character-Aligned Bitmaps (bmc)
Windows Help treats a bmc bitmap as a text character. It aligns the bitmap on the
baseline of the type in exactly the same place in the paragraph where the 
reference command occurs. Because the bitmap is treated as text, any paragraph 
formatting properties assigned to the paragraph also apply to the bitmap. Text 
coming before or after the bitmap does not wrap around the bitmap, but it may 
appear slightly higher on the line if any white space is saved at the bottom of the 
bitmap image.

Help files use bmc bitmaps in many ways. For example, you might include a 
bitmap in the explanation of an interface element. Figure 10.x shows how Word 
for Windows displays the bitmap reference in the topic file.
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Note

Don’t specify negative line spacing for a paragraph that has a 
bmc bitmap reference. If you do, the bitmap might appear on top of the
succeeding paragraph when Windows Help displays the topic.

After you compile your topic file, Windows Help displays the referenced 
bitmaps, as in Figure 10.x.

Graphic
Positioning Left-Aligned Bitmaps (bml)
Windows Help places a bml bitmap along the left margin, with text wrapping 
along the right edge of the image. Text is aligned with the upper-right corner of 
the bitmap, so any white space saved at the top of the image affects the way text 
appears in relation to the bitmap.

You normally place bml references at the beginning of a paragraph to ensure 
proper wrapping of text around the right edge of the bitmap. For example, a 
typical bml reference is formatted as follows:
{bml name.bmp}Paragraph text follows the bitmap reference...

Figure 10.x shows how a bml reference appears in the Word for Windows topic 
file.

Graphic

Note

Do not put any space characters between the bml reference and 
the paragraph text unless you want the first line of text indented from 
the rest of the text that wraps along the right edge of the bitmap.

After you compile the topic file, Windows Help displays the referenced bitmap to
the left of the text, as in Figure 10.x.

Graphic



   Microsoft Windows Help Authoring Guide

You can also put a bml reference at the end of a paragraph, as in this example:
...Paragraph text precedes the bitmap reference.{bml name.bmp}

Figure 10.x shows how this type of bml reference appears in the Word for 
Windows topic file.

Graphic
When you include a bml reference this way, Windows Help wraps the text to the 
paragraph end and then displays the bitmap. After you compile the file, the 
bitmap appears under the text and to the left, as in Figure 10.x.

Graphic
Positioning Right-Aligned Bitmaps (bmr)
Windows Help places a bmr bitmap along the right margin, with text wrapping 
along the left edge of the image. Text is aligned with the upper-left corner of the 
bitmap, so any white space saved at the top of the image affects the way text 
appears in relation to the bitmap.

You normally place bmr references at the beginning of a paragraph to ensure 
proper wrapping of text around the left edge of the bitmap. For example, a typical
bmr reference is formatted as follows:
{bmr name.bmp}Paragraph text follows the bitmap reference...

Figure 10.x shows how a bmr reference appears in the Word for Windows topic 
file.

Graphic

Note

Do not put any space characters between the bmr reference and 
the paragraph text unless you want the first line of text indented from 
the left topic margin.

After you compile the topic file, Windows Help displays the referenced bitmap to
the right of the text, as in Figure 10.x.

Graphic
You can also put a bmr reference at the end of a paragraph, as in this example:
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Paragraph text precedes the bitmap reference.{bmr name.bmp}

Figure 10.x shows how this type of bmr reference appears in the Word for 
Windows topic file.

Graphic
When you code a bmr reference this way, Windows Help wraps the text to the 
paragraph end and then displays the bitmap. After you compile the file, the 
bitmap appears under the text and to the right, as in Figure 10.x.

Graphic
Storing Bitmaps with Data
Each of the bitmap reference commands, bmc, bml, and bmr, has alternative 
forms ending with wd. Bitmaps positioned using the bmcwd, bmlwd, and 
bmrwd commands look the same as bitmaps positioned using the bmc, bml, and 
bmr commands. However, the commands ending in wd store the bitmap data 
differently in the Help file.

When you use the bmc, bml, or bmr command, the bitmap data is stored 
separately from the Help file text. A single copy of the bitmap is used for all 
bmc, bml, or bmr commands that display the same bitmap. Using these 
commands can therefore reduce the size of your Help file if you reference large 
bitmaps more than once in a file. The disadvantage is that Windows Help must 
retrieve the bitmap from the disk before displaying it in the topic, so these 
bitmaps may display more slowly than those referenced with the wd commands, 
especially if the Help file is stored on a CD-ROM disc.

Benefits

When you use the bmcwd, bmlwd, or bmrwd command, the bitmap data is 
stored in the same location in the Help file as the text. The bitmap data becomes 
part of the Help file, and this data appears in the location given by the command. 
When the bitmap is stored inline with the text, Windows Help may display it 
faster than if it were positioned using the bmc, bml, or bmr command because it 
doesn’t have to retrieve information from different locations on the disk. Reading
data from different locations on a CD-ROM is very time consuming, and it can 
also be slow on magnetic media. 

Moreover, storing bitmaps with data maximizes the benefits of using the 
OPTCDROM option in the Help project file. Help keeps up to 12K of 
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compressed topic text in memory. Since bitmaps with data are kept with the topic 
text, they take advantage of this buffering. So, generally, topics less than 12K 
after compression do not need to be re-read from disk when the window is 
resized or redrawn.

Limitations

The primary limitation of the wd commands is that each bmcwd, bmlwd, or 
bmrwd command stores a separate copy of the bitmap. That means your Help 
file will be larger if you use bitmaps stored with data than if you use the 
commands without wd, especially if you reference larger bitmaps more than 
once. Large bitmaps that are referenced using wd may also cause “out-of-
memory” error messages when compiled under MS-DOS.

Another limitation is that bitmaps stored with data cannot be more than 64K after 
compression. If the compression reduces the size of the bitmap to less than 64K, 
then you can store it with data. How much compression is achieved depends on 
the bitmap. That means you can have two different bitmaps that are 80K before 
compression, and one may compress to less than 64K and the other may not. 
Therefore, Help claims a 64K limit for bitmaps stored with data, even though the 
actual limit may vary slightly.

Because the Windows bitmap format does not include any compression, all 
bitmaps are compressed during the build by the Help compiler. If you want a 
quick way to determine how large the bitmaps will be when they are put into 
Help, you can use Hotspot Editor or Multi-Resolution Bitmap Compiler, since 
they compress bitmaps using the same mechanism as the Help compiler. If the 
bitmap is still too large, you may have to reduce its size or complexity.

Guidelines

Use the following guidelines to decide whether to use the normal or wd versions 
of these commands:

n Use bmc, bml, and bmr for all bitmaps that appear frequently in 
your Help file.

If a bitmap is used frequently, not placing it “with data” may be more 
appropriate, unless the performance benefit outweighs the size factor.
n Use bmcwd, bmlwd, and bmrwd for small bitmaps (less than 64K) 

that appear only once or infrequently in your Help file.
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Bitmaps with data use extra disk space only when the same bitmap is 
used more than once in the Help file. 
n Use bmc, bml, and bmr for large bitmaps (greater than 64K).
Large bitmaps stored with data may worsen performance if the topic is 
drawn twice to remove unnecessary scroll bars. If the topic is over 12K,
it will be read, laid out, and then read a second time as it is laid out 
without the scroll bars. Because bitmaps cause most topics to exceed 
12K, this problem is likely to occur if you store bitmaps with data. 
Bitmaps not stored with data, on the other hand, are kept in a different 
location from the text, so they are read from disk only once if the topic 
text is less than 12K.
n Use bmc, bml, and bmr for bitmaps that appear in two or more 

topics normally displayed in sequence (for example, in a browse 
sequence).

Help caches in memory the 50 most recently accessed bitmaps that are 
not stored with data. This means that a bitmap may only have to be read
from disk once if two Help topics reference it successively. Unlike 
bitmaps stored with data, these cached bitmaps have to be re-read only 
if they’re moved out of the cache by 50 new bitmaps, or by low 
memory conditions.
Cached bitmaps not stored with data degrade performance if they are 
displayed only once. Since they are stored in a different location from 
the topic text, Help requires an additional seek to locate them. This 
cost, if incurred, is generally negligible on magentic disks but high on 
CD-ROM. Nonetheless, this performance cost may be less than the cost 
of reading the topic twice if the topic is larger than 12K.

Creating Bitmap Hot Spots

You can do more with pictures in your Help file than simply display them. You 
can also create graphics, such as icons or buttons, and format them as hot spots. 
With a bitmap hot spot, the user can click any part of the graphic to activate the 
hot spot: jump, pop-up, or macro. Bitmap hot spots use the same formatting and 
positioning characterisitics as text hot spots, so you can use any bitmap or 
metafile as a hot spot.
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To format a bitmap as a jump hot spot

1. Type the bitmap reference (bmc, bml, bmr) in the topic file where 
you want to create the jump.
2. Select the entire bitmap reference, including the bitmap filename and
the opening and closing braces.
3. From the Format menu, choose Character.
4. Select the Double Underline check box, and then choose OK.
5. Position the insertion point immediately after the closing brace of the
bitmap reference.
Leave no spaces or characters between the brace of the bitmap 
reference and the insertion point.
6. From the Format menu, choose Character.
7. Clear the Double Underline check box, select the Hidden check box, 
and then choose OK.
8. Type the context string assigned to the topic that you want users to 
jump to when they choose this hot spot.
9. From the Format menu, choose Character.

10. Clear the Hidden check box, and then choose OK.

Figure 10.x shows the GLOSS.BMP bitmap correctly formatted to jump to the 
Contents topic of the Glossary Help file when it is chosen.

Graphic
To format a bitmap as a pop-up hot spot

1. Type the bitmap reference (bmc, bml, bmr) in the topic from which 
you want to display the pop-up window.
Be sure you have created the topic (and its context string) that will 
appear in the pop-up window.
2. Select the entire bitmap reference, including the bitmap filename and
the opening and closing braces.
3. From the Format menu, choose Character.
4. Select the Underline check box, and then choose OK.
5. Position the insertion point to the immediate right of the closing 
brace of the bitmap reference.
Leave no spaces or characters between the brace of the bitmap 
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reference and the insertion point.
6. From the Format menu, choose Character.
7. Clear the Underline check box, select the Hidden check box, and then
choose OK.
8. Type the context string assigned to the pop-up window topic.
9. From the Format menu, choose Character.
10. Clear the Hidden check box, and then choose OK.

Figure 10.x shows the RT.BMP bitmap coded to display a pop-up window (with 
the “rt05_how_pm” context string) containing all cross-references to the current 
topic when it is chosen.

Graphic
To format a bitmap as a macro hot spot

1. Type the bitmap reference (bmc, bml, bmr) in the topic file where 
you want the macro.
2. Select the entire bitmap reference, including the bitmap filename and
the opening and closing braces.
3. From the Format menu, choose Character.
4. Select the Double Underline check box, and then choose OK.
5. Position the insertion point to the immediate right of the closing 
brace of the bitmap reference.
Leave no spaces or characters between the brace of the bitmap 
reference and the insertion point.
6. From the Format menu, choose Character.
7. Clear the Double Underline check box, select the Hidden check box, 
and then choose OK.
8. Type an exclamation point (!) followed by the macro and its 
parameters that you want Windows Help to execute when the user 
chooses this hot spot.
9. From the Format menu, choose Character.
10. Clear the Hidden check box, and then choose OK.

Figure 10.x shows how to format the WINCLK.BMP bitmap so that Windows 
Help executes a macro starting the Clock application when it is chosen.



   Microsoft Windows Help Authoring Guide
Graphic

Assigning Bitmap Locations in the Help Project File

Once you have the bitmaps properly situated in the topic file, you must be sure 
the Help project file contains the information necessary to access and use them. 
This section describes the entries in a Help project file that are required to display
bitmaps.

When you use bitmap-reference commands to position bitmaps, you must tell the 
Help compiler where to find the bitmaps. The easiest way to do that is to include 
a BMROOT option in the [OPTIONS] section of the project file.

Note

Another way to identify bitmaps is to list the filenames 
individually in the [BITMAPS] section of your Help project file. This 
method is not recommended unless you are creating a Help file for 
Windows Help version 3.0. For more information about the 
[BITMAPS] section, see Chapter 16, “The Help Project File.”

The BMROOT option lists the paths where you want Windows Help to look for 
bitmaps positioned by the bmc, bml, and bmr references. You can give absolute 
paths or paths relative to the directory containing the Help project file. This 
option has the following syntax:

BMROOT=pathnames

For example, you can create a subdirectory off the main project directory where 
you keep all the bitmaps:
[OPTIONS]
    .
    .
    .
BMROOT=.\BMP
    .
    .
    .

Assuming the Help project file for the Help file is in the WIN31\HELP directory, 
this option tells Windows Help to look for bitmaps in the WIN31\HELP\BMP 
directory.
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You can assign more than one path to the BMROOT option; Windows Help 
searches all the paths, in the order given, for the specified bitmaps. Separate 
multiple paths with commas. For example:
[OPTIONS]
BMROOT=.\BMP, .\WMF, .\SHG

Ó 1993 Microsoft Corporation, All rights reserved
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